Pulse Pro Setup issues

I am very comfortable with technology and currently own/use a couple of Pulse monitors. I bought a Pulse Pro at the end of last year and just got around to setting it up today. I was able to get it connected to my network no problem and I can even see the light spectrum when I click on the spectrum tab. But my environmental data has not loaded for several hours.

I tried reconnecting the device to my network again and it will connect no problem but still no enviro data. The timestamp on the spectrum historical readings is working and a new reading is coming through every 4 minutes or so. But there is zero data coming through for the environment. My cheap regular pulse meters are working just fine on this same network and provide data in real time no problem.

Can someone please help me

Hi @Ripoz4200 seems like you’re up and running now according to my logs.

In the future, for more immediate support, hit up our support site: support.pulsegrow.com, there’s a chat window there and contact info if you want to call.